Supavisor error: 'Circuit breaker open' after password rotation #50259
Replies: 1 comment 1 reply
|
Supavisor error: "password authentication failed" after rotating database password fix this |
1 reply
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Uh oh!
There was an error while loading. Please reload this page.
This is a copy of a troubleshooting article on Supabase's docs site. It may be missing some details from the original. View the original article.
If you are seeing
FATAL: Circuit breaker openwith one of the error messages:failed to retrieve database credentials after multiple attempts, new connections are temporarily blockedtoo many failed attempts to connect to the database, new connections are temporarily blockedtoo many authentication failures, new connections are temporarily blockedit indicates that the connection pooler has blocked the origin IP to protect the database.
This typically happens when clients attempt to connect to the pooler (ports 5432 or 6543) using an outdated password after a rotation.
Why Does This Happen?
How to Resolve This Issue:
Prevention:
To avoid this IP lockout issue in the future, stop application instances before rotating the database password. Only restart your services once the new credentials have been successfully applied to your configuration.
See also:
All reactions