Repository navigation
Minor release. The minimum PHP version is now 8.3; the public API is unchanged.
Removed
- Support for PHP 8.1 and 8.2, deprecated in 2.1.5. The required PHP version is now
^8.3(was^8.1). Composer does not install this release on PHP 8.1 or 8.2, so those projects stay on 2.1.5. PHP 8.1 reached end of life on 31 December 2025 and does not receive PHP security fixes; PHP 8.2 reaches end of life on 31 December 2026.
Changed
- CI matrix now covers PHP 8.3 / 8.4 / 8.5.
- The exception security tests no longer fall back to
zend.exception_ignore_args=Onfor PHP 8.1.
Notes
- 2.1.5 announced that PHP
^8.3would be required from 3.0. It ships in this minor release instead: public class names, method signatures, return types, and thrown exception types are unchanged, and Composer's platform check keeps PHP 8.1/8.2 projects on 2.1.5.
Upgrading
Run PHP 8.3 or newer on the latest patch release of its branch (at least 8.3.36, 8.4.27, or 8.5.12 for CVE-2026-109618 and CVE-2026-109619 — see the PHP security advisory). Existing ^2.0 / ^2.1 constraints pick up this release automatically; no application code changes are required.
composer update spontena/pb-phpFull Changelog: v2.1.5...v2.2.0