HTTP API client libraries

Luiza Pagliari edited this page Mar 30, 2017 · 27 revisions

There are a number of client libraries for Etherpad Lite's HTTP API. Please help us keep them up to date!

Ruby

Source

Documentation

Rubygem

API Version support 1.x

Javascript (node)

Source

npm package

Version support 1.0 - 1.1.1

Python

python-etherpad_lite:

PyEtherpadLite:

  • Source
  • Version support 1.0 - 1.1

Perl

Etherpad::API (deprecated, CPAN)

Etherpad

Source

CPAN

Version support 1.0 - 1.2.12

PHP

Source

Version support 1.0 - 1.1.1

Source, Packagist *Warning: requires composer.

Version support: 1.3

Java

Source

Version support 1.1 - 1.2

Objective-C

Source

API Version support 1.x

.NET

Source

Version support Unknown

Go

Source

API Version support 1.2.13

General

Resources

For Developers

How to's

Set up

Advanced steps

Integrating Etherpad in your web app

for Developers

Clone this wiki locally
You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.
Press h to open a hovercard with more details.